Trying to set up Sia Host on Raspberry Pi 4. Bootstrapping keeps timing out

So I started following this guide to set up my raspberry pi 4 to run a Sia host and I am using the command provided to bootstrap the Sia node.

wget --tries=inf -O blank-siad-260k.tar.gz ""

However when I run it I keep timing out on my connection. I am hardwired in to my router and have 1gb/s download and about 700mb/s upload. Is there a new updated way of bootstrapping the Sia node that could explain why this isn’t working?

P.S. I have tried connecting my laptop through the same connection as the raspberry and I can connect to the internet just fine. I have also ensured that there is nothing blocking the connection (ie. Firewall) and have tried all the different web portals available. I’m stumped.

Photo of terminal output:

Think I found the offical repository, can anyone verify for me that this is correct? Just not sure because it is still under Nebulous Labs.

Either way it is now currently halfway through bootstrapping :smiley:

Yes that is the correct repo
They will be splitting in 1.5.6 in a couple of weeks
Also I’d recommend this bootstrap link