Problem restoring wallet

Hello,

i just moved my computer to a new one, checked all things on new and everything was fine - just forgot the SIA Wallet. i tought i have the seed (because i have some) - but the one with over 500.000 SIA on it i can’t find.

so went back to old backup - SIA 1.5.5 should be already installed, but not 100% sure, it was in downloads.

so i put back the SIA-UI in Roaming Profile folder - tried to startup, but it won’t (also tried to copy from local profile / programs / SIA-UI too)

Errors like that are coming up.
error: [server is unable to create the Sia node; unable to create gateway; unable to load gateway; unable to read persisted json object from disk: unable to read header from persisted json object file: invalid character ‘\x00’ looking for beginning of value]

i’m pretty sure i also moved the coins to the new Chain.

i don’t know why this is not working - because the old computer is still running

Very important to keep your seed safe: https://support.sia.tech/your-sia-wallet/the-importance-of-your-seed

When checking balance with Sia-UI keep in mind that your balance will not show until after the node has fully synced and the wallet has been scanned. The initial wallet scan can take a few hours after the node has finished syncing. You can check the status by comparing the current block height to the height of the wallet in Sia-UI’s terminal with the wallet command.

That error means the gateway folder you copied in was corrupted somehow. You can rename the gateway folder in %APPDATA%/Sia-UI/sia to gateway_old to workaround the error, but if that folder is corrupted there is likely other corruption as well.

If the old computer with your 500KS is still running and your wallet is unlocked:

  1. Open Sia-UI’s built in terminal
  2. Type wallet seeds into the textbox at the bottom, then press enter
  3. Your 28/29 word wallet seed will be displayed in the output window.
  4. On the new computer, start with a clean install of Sia-UI: https://support.sia.tech/your-sia-wallet/sia-ui-faqs/how-to-perform-a-clean-install-in-sia-ui
  5. Recover your wallet seed

If you do not know the seed, but have the wallet folder and know the encryption password:

From the old computer:

  1. Stop Sia-UI and make sure no Sia-UI or siad processes are still in Task Manager
  2. Open %APPDATA%/Sia-UI/sia
  3. Transfer the wallet folder to the new computer

On the new computer

  1. Start with a clean install of Sia-UI: https://support.sia.tech/your-sia-wallet/sia-ui-faqs/how-to-perform-a-clean-install-in-sia-ui
  2. Open %APPDATA%/Sia-UI/sia
  3. Copy the wallet folder from the old computer
  4. Start Sia-UI and wait for sync
  5. Unlock your wallet
1 Like

if the old computer SIA GUI would work i won’t have a problem ;)
but no it’s not working, i have 4 seeds with coins on it, but there are just some tousands on it, the big one is missing.

i also run a fresh SIA installation on a new computer - it works great, and wa synced after a day or something like that.

tried 4 times logging off and on to confirm evertime working.

so i thought i just put the wallet file in it - after doing it, the error occours, when putting back the other wallet file, working great again…

tried also 4 different wallet files from shadow copies of the old computer… so i don’t know how i can access it.

maybe i need an old installation to get it running again?