sia-ui 1.1.2 starts up, sia-ui 1.2.1 does nothing (win10 x64)

  • I wanted to try Sia, so I downloaded sia-ui 1.2.1.
    I unzipped it, started sia-ui.exe and nothing happened. Not even a window appeared. Looking in the Windows task-manager I see two Sia-UI.exe processes, but no activity.

    After trying a few times (rebooting PC and such) I downloaded sia-ui-1.1.2, unzipped it and it started up no issues (I see tons of sia-ui.exe processes now running :P).

    Started playing with Sia using sia-ui-1.1.2 (got so far as to get some money in the wallet, get some allowance, get some contracts and even uploaded some files).

    Here it comes, I then started sia-ui-1.2.1 again (By accident). But it worked this time! It started up, no issues.
    I rebooted my PC again for something else, then I wanted to start sia-ui-1.2.1 again, but this time the same as before: It won't start up, it won't show anything.

    So I started the old sia-ui-1.1.2 again. It started but gave tons of errors. Probably because some incompatibilities between the two versions.

    So now I have a 1.2.1 that won't start up, won't show UI or window or error or what so ever. and I have a 1.1.2 that gives tons of errors...

    The only somewhat-workable solution I have now is that I start siad.exe manually from the 1.2.1 release (which works fine), and use the siac.exe CLI client from 1.2.1 release (which works fine). I can then even start the 1.1.2 UI (with the newer siad.exe already running) and it seems somewhat OK, but I get tons of annoying 'UI' errors messages when I try to upload files. Uploading does seem to work and start though.

    It's the uploading I want the UI for! All other stuff I can do fine with the siac CLI client, but uploading whole folders is a pain if not impossible with the siac.exe client, and it seems impossible to read files with + signs in the filename (it gives an error it can't read the filename which has the + signs replaced with a space!)

    Is there some trick to get the 1.2.1 UI running OK? Where are the logs for the UI so I can check why nothing is happening? (the logs for siad are neatly in my %appdata% folder, but I see nothing of value there for why the 1.2.1 UI won't show)

  • So 1.2.0 starts up fine, 1.2.1 still doesn't. Tried redownloading, extracting again, running as admin, nothing.
    I can't be the only one with this, right?

  • you are not the only one. Same for me and lots of people.

  • I'm in the same boat... I have not found one good solution on the forum.

  • Same here

  • 1.2.2 no change, so something broke in 1.2.1, and at least I'm not alone :)
    bump bump

  • bump bump

Log in to reply