Bootstrap Download for Sia Blockchain ("Consensus") for v1.1.2

  • I recently installed Sia and it took 3 days to synchronize.

    Could a copy of the Sia "Consensus" blockchain be posted for download? This would help people that want to try Sia get started more quickly.

    Or, better yet, is there a light client in the works?

    PS: I see an older consensus version posted here:
    Re: Consensus DB downloads


  • Just noticed on the Sia Roadmap that the "Initial blockchain sync time to be reduced dramatically" in 6 months. Looking forward to it! :)

  • Global Moderator

    The consensus db generally stays compatible throughout all releases. If the compatibility would be broken eventually the dev team would probably announce it and provide a compatibility layer.

    The downloads in that thread should work with any version of Sia

  • @Fornax Thanks - I tried that and the Consensus DB download for v1.1.1 worked just fine for the current version, 1.1.2!

    I also installed Sia on a newer computer with a SSD, and the consensus sync from the network went over 5x as fast! Much better. The slowness was maybe just my fault for using an old computer, lol.

  • admins

    Sia is much, much faster on an SSD. This mostly our fault for writing code that is unnecessarily brutal to the hard drive. We have plans to fix it, but not in the near future (we want to make it safe to delete files locally and to back up .sia files first).

  • @Taek - Great, I like where your priorities are at. Glad to see the progress so far :)

  • Just starting out and trying to get set-up. After nearly 24 hours I found this thread and have downloaded the bootstrap consensus file.
    When starting up siad again, it spits out the folowing and then nothing seems to happen after that. I have waited over an hour, but nothing... :-/
    I am guessing I still need steps 4, 5 and 6 to complete before I can proceed...

    (0/6) Loading siad...
    (1/6) Loading gateway...
    (2/6) Loading consensus...
    (3/6) Loading transaction pool...

    Any ideas if siad just takes a long time to fully boot up or if I should be looking for an error somewhere?

  • Global Moderator

    @XyzAbc loading the transaction pool takes a few hours after loading an external DB. Just be patient, it should eventually continue. :)

  • admins

    Worth noting that in v1.2.0, loading the transaction pool will only take a few minutes. The wallet can also take a few minutes, but as a tradeoff unlocking the wallet will be instant. (these delays only apply to who skip syncing by downloading a consensus database)

  • I copied the consensus.db (10 GB) to Appdata folder and for 2 days is shows the message that Sia is loading.I have a laptop with CPU i7-3200Mhz and memory 8GB and HDD Seagate 1TB at 5200 rpm.I saw that there is a consensus txt file that rises in size but slowly now is at almost 2MB.
    Is there a way to make it work faster? I seems that to me is the same time bootstraping or syncing SIA UI.I think it was better if it has a official server to connect option to without downloading tones of files and waiting a week to use the wallet.

Log in to reply