Sia-UI on FreeBSD



  • Hello!

    I just tried to run Sia-UI on FreeBSD.
    node v6.9.1 and npm 3.9.2 installed

    Some time install process works normally, but then this error displayed:
    npm install

    [email protected] install /home/alex/Sia-UI-master/node_modules/electron-chromedriver
    node ./download-chromedriver.js

    Downloading https://github.com/electron/electron/releases/download/v1.4.0/chromedriver-v2.21-freebsd-x64.zip failed: Non-200 response (404)
    [email protected] /home/alex/Sia-UI-master
    └── (empty)

    npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
    npm WARN notsup Not compatible with your operating system or architecture: [email protected]
    npm ERR! FreeBSD 10.3-RELEASE-p11
    npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
    npm ERR! node v6.9.1
    npm ERR! npm v3.9.2
    npm ERR! code ELIFECYCLE

    npm ERR! [email protected] install: node ./download-chromedriver.js
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the [email protected] install script 'node ./download-chromedriver.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the electron-chromedriver package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! node ./download-chromedriver.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR! npm bugs electron-chromedriver
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR! npm owner ls electron-chromedriver
    npm ERR! There is likely additional logging output above.

    npm ERR! Please include the following file with any support request:
    npm ERR! /home/alex/Sia-UI-master/npm-debug.log
    npm ERR! code 1


  • admins

    Have you tried running other electron projects on FreeBSD?

    To me this looks like an Electron issue, and not something specific to the Sia codebase. the:

    npm ERR! node v6.9.1
    npm ERR! npm v3.9.2
    npm ERR! code ELIFECYCLE

    errors indicate to me that something is probably out of date. Perhaps npm? I don't think your node version is too old to work.



  • Hmm...
    I'll learn more about this and shall post info here.


Log in to reply