Wrong Password - see GitHub



  • Hey, this is on a fresh copy of Darwin Sia 5.1

    When I create a wallet, I get the dialog with the passphrase, but I can not close it by clicking the upper right X or clicking "OK I've written it down".

    Trying to unlock the wallet with the given dialog gives a Wrong Password error. I am 100% sure of the passphrase, I just copy and paste it straight from the box. I've tried unlocking it with the open passphrase dialog or closing the app and reopening it.

    edit : This is 3 bugs going on at the same time

    https://github.com/NebulousLabs/Sia-UI/issues/200
    https://github.com/NebulousLabs/Sia-UI/issues/201
    https://github.com/NebulousLabs/Sia-UI/issues/202



  • Did you try to Save the password at the same time? I've noticed that if you select Save password when unlocking the wallet, the passphrase dialog doesn't close.

    If its not too much trouble, and your wallet doesn't have any funds in it yet, shut down Sia, deleted the wallet directory in the installation directory and restart Sia and try again.



  • I've tried deleting the wallet folder and restarting a new wallet from scratch several times.

    I've tried checking the Save password box, but I still get the same error. That is a big problem because then Sia doesn't forget the wrong password and doesn't give you the chance to try with a different one, so all you can do is get the wrong password error over and over again as you try to unlock your wallet.


  • Global Moderator

    The Save Password option is broken in the UI. Don't use it. Hopefully it should be fixed in the next version.

    Oh, and it might be that the old password is saved in config.json and that's why you're getting the error. Check if the password is saved there and remove it (if you're ok with editing a json file). Always backup a config file before changing it!



  • HAH, good catch, so here's what I found out:

    1. the string you copy from the dialog box is polluted by the button label. Here is the actual string from config.json:

    "password": "balding motherly roles pram lodge knuckle different haunted salads drowning tell alpine rejoices potato intended sleepless jeers cedar optical upgrade stunning tubes tissue hedgehog rumble moon razor jolted against I've recorded this in a safe place!"

    As you can see, "I've recorded this in a safe place!" manages to sneak into the buffer. To select the password, I double clicked on the passphrase, and only that gets highlighted before I copy, but somehow the button label is also included.

    I was not realising this was happening because when you paste the password into the password dialog, you only see the dots.

    Workaround: Carefully click and drag around the passphrase to select only that when copying the string.

    Fix: Get doubleclicks on the passphrase to only select the passphrase and not that extra bit of text at the end.

    1. There is still a problem with that dialog box not reacting to clicks.


  • Ok, that should be a simple fix. Feel free to submit a PR on github to correct this.

    About 2: I noticed the dialog doesn't respond to clicks if Save has been selected. Otherwise, it worked ok (for me at least).



  • On my end, the Passphrase Save option works fine for me (as in passing the password to siad and saving it for future use). However, it does not let me change it if I got it wrong.

    I've individuated 3 distinct issues and submitted them to GitHub


Log in to reply