A sia-ui error has occured error: sia closed unexpected



  • @brwainer I've checked listening ports in resource monitor and the only entry for port 9980 is:
    Image: siad.exe process ID: 7476 address: IPv4 loopback

    The same siad.exe process ID are listed on ports 9981 & 9982. How should I proceed?



  • @Taek I am having a similar problem on my linux machine (elementary OS)



  • @augustus it sounds to me like you already have one said instance running (in the background?) and are trying to launch another. If that's not the case then you'll have to wait for someone more knowledgeable to answer and let you know what needs to be deleted in order to reset the state of sia.



  • I've restarted several times and checked that no siad processes are running, so not sure why siad.exe is being listed as listening to port 9980. @Taek can you shed some light? My hosting has been offline for over a week now!



  • @augustus if a process is bound to a port, and you can't close it via normal means (i.e. you don't have a command prompt open for it, and it isn't showing in the taskbar tray as an icon you can right click) then you have to kill the process from task manager or a similar program. Or restart the computer, that closes all processes. Sai doesn't have any automatic startup, so it wouldn't start on boot/login unless you manually set that up yourself.



  • @brwainer I'm struggling to see how what your stating fixes the problem. I've restarted my computer several times which does indeed free up port 9980, but Sia-UI still won't start. The same problem still occurs.


  • admins

    @augustus sorry for the slow reply. Been buried. if you are getting the error: "listen tcp 127.0.0.1:9980: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted." when you try to start the UI, it means that there's another program somewhere using that port.

    It is a weird error though, if Sia is already available at port :9980 the UI should just automatically connect to it, instead of complain.



  • @Taek so to clarify, this means you have no idea how to fix the issue? In which case I will reinstall so I can access my wallet. But I'll no longer be hosting. I've experienced far too many problems and am tired of software issues outside of my control leading to financial penalties.


  • admins

    Sorry to hear that. But the error you are reporting is very unusual.



  • @Taek I've managed to get the Sia-UI working again. I backed up the storage folder & Sia-UI folder (containing GPUCache, consensus, gateway, host, etc folders) wiped Sia and re-downloaded and reinstalled. Copying over the backed up files seems to have worked as the block is almost fully synced, wallet seed is present and can be accessed. I've proceeded to add the old storage folder however I'm unsure if this is enough to make previous client data accessible. Is there any way I can determine if clients are able to access their data and that everything is running as it should be?



  • @Petar1989 I'm in the same situation too.I've already solved the problem by finding the corrupted json file.My host.json file which is in the host folder is corrupted! So I delete the file and restart sia-ui,it goes well now!
    The corrupted file maybe not host.json file ,it can be other json file.So we just need to check the json files in the AppData folder.


Log in to reply