A sia-ui error has occured error: sia closed unexpected



  • A sia-ui error has occured error: sia closed unexpected

    Can someone tell me what to do? muy pc restarted 3 times and Sia wallet was opened, now i cannot open? Do u know guys how to repair this?



  • It could be that a file in your data directory has been corrupted, but as long as you remember your seed you'll be able to access your money. Are you running on Windows, Mac, or Linux?

    If you could run the following command from either the Command Line/Terminal and post your results here we can help you get back up and running.

    Windows
    Open a Command Line cmd and cd to your Sia-UI's Sia folder. It will look something like Sia-UI-win32-x64\resources\app\Sia\ . You should see a program called siad there. Run the following command and post the results: siad --sia-directory %APPDATA%/Sia-UI/sia

    Mac
    Open the Terminal Application and cd to yoru Sia-UI's Sia folder. It will look something like Sia-UI.app/Contents/Resources/app/Sia/. You should see a program called siad there. Run the following command and post the results: ./siad --sia-directory ~/Library/Application\ Support/Sia-UI/sia

    Linux
    Open a terminal and cd to your Sia-UI's Sia folder. It will look something like Sia-UI-linux-x64/resources/app/Sia/. You should see a program called siad there. Run the following command and post the results: ./siad --sia-directory ~/.config/Sia-UI/sia



  • I'm in the same situation. My machine crashed during blockchain sync and I'm having the same error message. The above mentioned command reports this:

    C:\STUFF\SIA\Sia-UI-win32-x64\resources\app\Sia>siad --sia-directory %APPDATA%/Sia-UI/sia
    Loading...
    (1/7) Loading gateway...
    (2/7) Loading consensus...
    (3/7) Loading transaction pool...
    (4/7) Loading wallet...
    (5/7) Loading miner...
    miner persistence startup failed: invalid character '\x00' looking for beginning of value

    How can this be fixed?



  • I've figured it out. I purged everything is Sia folder (C:\Users\USERNAME\AppData\Roaming\Sia-UI\sia) except consensus and wallet, deleted and reinstalled Sia-UI, launched it, watched "Loading Sia" screen for about 10 min as it rechecked blockchain and then I was able to continue syncing.



  • Just to check, are you running Windows? We've seen this issue affect few users, and have tracked it down to the way Windows does "safe" file writes. Simply put they aren't safe, and as a result the config ie .json files Sia uses can be corrupted in case of unsafe shutdown. The good news is that Sia can regen these files if you delete them, but it needs to do a full rescan which can take ~10minutes as you've said.

    Either way glad to see your back up and running. Do you have any copies of the corrupted files by chance?



  • Mine is Win 10 64x. It was exactly as you say, it regenerated files and I'm able to mine now. If you need corrupt sia folder files for examining here they are, I made a copy right after the crash:
    http://dropmefiles.com/sjQ2m



  • Hi everyone,

    FYI I just had the same issue on a W10 64-bit machine after a crash.

    What i had to do is delete the storagemanager.json file (C:\Users\xxx\AppData\Roaming\Sia-UI\sia\host\storagemanager), because it only contained some tabs and spaces. After I deleted this file I could properly start SiaUI and the file got recreated.

    UPDATE: This did not really help at the end, because my Storage Folders disappeared. I am speaking to the devs about it, I'll update this post once I figure out who to solve this issue.

    UPDATE 2: Unfortunately all my contracts and money are lost :( I got the info from devs that I was probably the only one this happened to, but without this file I have basically lost all the data that is needed for hosting my files and contracts.

    So I now re-created the Stroage Folder and started from scratch. I can live with loosing a couple of thousand SIA coins, but I'll be backing up my files like crazy from now on.

    Supposedly this only happens on Windows and it will be better in v1.2 (I am using 1.1.0).



  • I've got this under windows 7 x64 and I use a seperate foder on a other hdd but still have the files in
    C:\Users\USERNAME\AppData\Roaming\Sia-UI\sia, I have atleast 54 contracts before, how to recreate now, what should I delete in that folder to startup sia again ?

    Regards Peter


  • admins

    Dev here. First thing I need to say is that I really appreciate you all posting this. Clearly it's not a rare or isolated issue, but something we need to spend more time digging into. Secondly, the topic of this thread has really changed to being about file corruption, and not just about Siad crashing.

    Second, for anyone reading thing, if you are having this problem on a machine that is not Windows, please speak up. Right now I'm assuming that this is a windows only problem, which is going to cause a lot of grief if my assumption is incorrect (but it's a great shortcut if my assumption is actually correct).

    Third, is anyone having problems with corrupted files other than their storagemanager.json?

    I am sorry for the issues that this is causing. We're definitely looking into it.



  • @Taek Would this corruption of the storagemanager.json that is being discussed in this topic also have been related to my own issues with storagemanager.json (and I think other files as well, but not sure) getting corrupted? My issue is: http://forum.sia.tech/topic/798/corrupt-host-folder-paths/6


  • admins

    They most likely are related. My hands are full for the next 2 weeks or so, but after that I'm intending to work full steam on the host + storage manager until we've fixed the bugs that have been showing up.



  • Hello, I received the same error after a power failure. But the solution did not help. If I delete the folder AppData\Roaming\Sia-UI\sia\host
    the program starts, but does not give me to set up the same folder of saved files

    I tried to set up by hand in storagemanager.json
    "Path": "E:\sia",
    "UID": "qfvyRA==",

    But:
    C:\Users\BornToRun\Downloads\Sia-UI-v1.1.0-win32-x64\resources\app\Sia>siad --si
    a-directory %APPDATA%/Sia-UI/sia
    Loading...
    (0/7) Loading siad...
    (1/7) Loading gateway...
    (2/7) Loading consensus...
    (3/7) Loading transaction pool...
    (4/7) Loading wallet...
    (5/7) Loading miner...
    (6/7) Loading host...
    Closing miner...
    Closing wallet...
    Closing transaction pool...
    Closing consensus set...
    Closing gateway...
    unexpected EOF

    And:
    Error Adding Folder
    symlink E:
    C:\Users...\AppData\Roaming\Sia-UI\sia\host\storagemanager\9a9775c7: A required privilege is not held by the client



  • @Taek Since a windows update and system restart I've been unable to get Sia-UI working. I've had the same 'A Sia-UI error has occurred: Siad unexpectedly closed' error message as others. I managed to get the UI open by running siad in the command prompt, but the block wasn't synched and it won't let me open the wallet. So I ran the command as requested and got this:

    C:\Users\Owner>C:\Sia-UI-v1.0.4-win32-x64\resources\app\Sia\siad --sia-directory %APPDATA%/Sia-UI/sia
    Loading...
    (0/6) Loading siad...
    (1/6) Loading gateway...
    invalid character '\x00' looking for beginning of value

    I have a substantial number of contracts and host data, so need to avoid wiping and starting again. Otherwise this will be the last straw for me. Any suggestions?


  • admins

    @augustus Delete your gateway folder, you shouldn't need to delete anything else. Also, upgrade to v1.2.0 - the most recent release. It is a lot more stable.



  • @Taek I deleted the Gateway folder and was able to log in, access my wallet and continue hosting. I then proceeded to carry out the update to version 1.20 as suggested. But since then opening Sia-UI results in a constant 'Loading Sia...' message. I've closed down and restarted several times, even left it in the loading state for over 24 hours, but it refuses to load up. What now?



  • Yeah got this too cant seem to make it run again lost about 62k and one tb worth of contracts. think im done now..



  • This post is deleted!

  • admins

    The host upgrade takes about 1 hour per 50GB you are storing. Unfortunately, this also includes storage you have allocated but is not in use.

    We have a fix coming up which should improve things substantially. Should be available tomorrow.



  • @Taek Ok... new fault. Sia-UI won't launch at all now. Carried out the same diagnostic as before. Results below:

    C:\Users\Owner>C:\Sia-UI-v1.0.4-win32-x64\resources\app\Sia\siad --sia-directory %APPDATA%/Sia-UI/sia
    Loading...
    (0/6) Loading siad...
    listen tcp 127.0.0.1:9980: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.

    Any suggestions?



  • @augustus That indicates that you already have a process bound to that ip:port - you can use Resource Monitor to find out what is listening on that port and close or change it.



  • @brwainer I've checked listening ports in resource monitor and the only entry for port 9980 is:
    Image: siad.exe process ID: 7476 address: IPv4 loopback

    The same siad.exe process ID are listed on ports 9981 & 9982. How should I proceed?


Log in to reply