Seem to have lost all my contracts, help!

  • I've been hosting for over 6 months. Had about 300 GB used(decided to recover my coins so set accept contracts to false a while ago) and hundreds of contracts:

    Was trying to transfer some coins from my host wallet and got this error:

    error after call to / wallet/siacoins; unable to fund transaction; wallet has coins spent in incomplete transactions - not enough remaining coins

    So i read around a bit and decided to resync the consensus.db hoping it would fix it. Closed Sia. I decided to move the existing consensus.db and it's log out to another folder. Then launched Sia again and was waiting for it to sync. For some reason it was saying that i just upgraded to a new version which i didn't do. Fast forward a few hours sync finished having all my host settings but suddenly i had no contracts!!
    Tried a few restarts, tried replacing the new consensus.db with the old one but no use still 0 contracts. My host.json file is saying contractcount = 0. Any ideas how i could get the contracts back?

    Also after resyncing the consensus db the host log is full of these
    update.go:88: Unable to submit contract transaction set after rescan: xxxxxx

    In the host logs now i keep getting this: incoming RPCDownload failed: download iteration failed: download request rejected: failed to load sector: could not find the desired sector

    Still have a lot of collateral to get back
    alt text

  • Anyone else had this issue? Still facing the problem!!

Log in to reply