Upgrade Sia-UI v1.2.2 to v1.3.0 fail



  • A critical error loading sia occured: Siad unexpectedly exited. Error log: Loading..
    (0/6) Loading siad...
    (1/6) Loading gateway...
    (2/6) Loading consensus...
    closing gateway...
    difficulty adjustment hardfork incompatibility detected

    Any ideas??



  • Forgot to mention that it is win32-x64 version.



  • go to C:/user/your account name/appdata(this one is hidden folder)/Roaming/Sia-Ui/sia/consensus

    in there change consensus.db to consensus.db.old and then run Sia-Ui. once you done that it will make new consensus.db

    I was able to fix this problem by doing that took me 3 to 4 days to figure it out.

    good luck.



  • I had a same problem with mac and I fixed it by doing the following steps.

    Click "Go" (You will find "Go" at the top of left bar)

    • then click "Go to folder"
    • then type "~/Library/Application Support"
    • find siaUI folder and delete it.
      Thats pretty much I did and it worked.

Log in to reply