Error message when trying to load the UI after update. Please help.

  • Hi all,

    After updating to the latest version I can no longer start the SIA UI. I get the following error message:

    A critical error loading Sia has occured: Siad unexpectedly exited. Error log: Loading...
    (0/6) Loading siad...
    (1/6) Loading gateway...
    (2/6) Loading consensus...
    (3/6) Loading transaction pool...
    (4/6) Loading wallet...
    Closing transaction pool...
    Closing consensus...
    Closing gateway...
    panic: page 143495 already freed

    goroutine 1 [running]:*freelist).free(0x421ce43c0, 0x50bc3, 0x8644f64000)
    /home/luke/go/src/ +0x29a*node).spill(0x421d06150, 0x421c90f98, 0x8)
    /home/luke/go/src/ +0x1e0*Bucket).spill(0x421cdc2b8, 0x1bf8ef8d, 0x1aef800)
    /home/luke/go/src/ +0x17b*Tx).Commit(0x421cdc2a0, 0x0, 0x0)
    /home/luke/go/src/ +0x125*DB).Update(0x421d041e0, 0x421c91328, 0x0, 0x0)
    /home/luke/go/src/ +0xf7*BoltDatabase).checkMetadata(0x421ce4570, 0x16e10d8, 0xf, 0x16cfdaf, 0x5, 0x0, 0x0)
    /home/luke/go/src/ +0x98, 0xf, 0x16cfdaf, 0x5, 0x421e506e0, 0x44, 0x421c91460, 0x10dcbaf, 0x421c914e8)
    /home/luke/go/src/ +0x144*Wallet).openDB(0x421c74f20, 0x421e506e0, 0x44, 0x421e506e0, 0x44)
    /home/luke/go/src/ +0x6f*Wallet).initPersist(0x421c74f20, 0x421c74f20, 0x421ce4240)
    /home/luke/go/src/ +0x306, 0x421d3db80, 0x19e99a0, 0x421c74840, 0x421e885c0, 0x3a, 0x0, 0x0, 0x0)
    /home/luke/go/src/ +0x1eb
    main.startDaemon(0x0, 0x0, 0x7fff5fbffd27, 0xe, 0x7fff5fbffd53, 0x5, 0x7fff5fbffd42, 0x5, 0x0, 0x7fff5fbffda7, ...)
    /home/luke/go/src/ +0x140c
    main.startDaemonCmd(0x421c7d200, 0x421c15310, 0x0, 0x5)
    /home/luke/go/src/ +0x162*Command).execute(0x421c7d200, 0x421c0a0d0, 0x5, 0x5, 0x421c7d200, 0x421c0a0d0)
    /home/luke/go/src/ +0x299*Command).ExecuteC(0x421c7d200, 0x16fce88, 0x3b, 0x421d4caa0)
    /home/luke/go/src/ +0x339*Command).Execute(0x421c7d200, 0x1aefba0, 0x16e58f7)
    /home/luke/go/src/ +0x2b
    /home/luke/go/src/ +0x7aa

    Deleting and downloading again did not help.
    I reached out tot the support but so far no reply other then it will be send to the dev team. Anyone know what i can do to get it working again?

    Kind Regards Roeland

  • Global Moderator

    @roelanddejong Try deleting your wallet file. it should be in users/username/appdata/roaming/sia/wallet. Make sure you save your seed so you can recover your wallet after.

    Make sure you tag me @bryan if you need to me respond.
    Forum Mod. I cannot fix transactions. I can't help with Mac or Linux.
    alt text
    Unofficial Web Based Siacoin Wallet. No more syncing.


Log in to reply