errors after every reboot



  • @maol All of the output was initiated by siad.exe - it closed everything itself.



  • @reinisp

    Renter log:
    2017/09/16 03:39:25.279522 persist.go:403: STARTUP: Logging has started.

    That's all that was in it. The contractor log in the same folder however is nearly 50MB, and that's just logging for yesterday alone. it's relentlessly repeating stanzas of this:

    2017/09/16 03:39:25.276515 contractor.go:178: STARTUP: Logging has started.
    2017/09/16 03:44:18.562783 update.go:57: Unable to save while processing a consensus change: rename C:\Users\paul\AppData\Roaming\Sia-UI\sia\renter\contractor.journal_tmp C:\Users\paul\AppData\Roaming\Sia-UI\sia\renter\contractor.journal: Access is denied.
    2017/09/16 03:44:18.565909 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.573930 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.574934 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.577941 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.579946 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.580949 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.582954 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.584960 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.587968 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.589973 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.591979 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.598997 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16 03:44:18.602006 update.go:57: Unable to save while processing a consensus change: invalid argument
    2017/09/16

    Now, having written that out, it gave me the idea to try running the Sia-UI as Administrator - which I just did - and still no luck, same error.



  • @anastrophe said in errors after every reboot:

    2017/09/16 03:44:18.562783 update.go:57: Unable to save while processing a consensus change: rename C:\Users\paul\AppData\Roaming\Sia-UI\sia\renter\contractor.journal_tmp C:\Users\paul\AppData\Roaming\Sia-UI\sia\renter\contractor.journal: Access is denied.

    I've not seen that error before, but my guess is on some kind of permission problem. Did you try uninstalling, then completely wiping all involved directories before reinstalling?



  • @maol At this point I'll try anything! starting the process now...kind of a shame there's no formal uninstaller...(i'm on win10)



  • @anastrophe No luck. Same issue. I'm pretty much ready to sell my coins, this is too much trouble.



  • @anastrophe I'm sorry to hear about your troubles! I'm fairly certain it's something in the way your specific computer is setup with permissions in directories etc. If you have a chance of trying this out on another computer it should work with no problems. Have you considered running Sia in a VM or on your NAS? I've done both, should work well for you too.

    This just in case you're willing to put in more effort, of course :-)



  • It was late last night, I was frustrated. I still am frustrated, but just not grumpy. :)

    I appreciate your help and efforts. I'm stumped at this point - so I think I'm going to try bothering the devs directly over on github, since this is seriously a weird repeated failure. If we find a solution, I'll be sure and check back in here.

    thanks again!



  • @anastrophe devs will be grateful if you can show / demonstrate how to repeat the issue. If it's not repeatable, there's nothing they can learn from it. Hence my suggestion to see if there's anything about your setup that will lead to the same problem on another computer.



  • Opened ticket. It's working now, but it's peculiar to say the least.
    https://github.com/NebulousLabs/Sia-UI/issues/721
    oh well!
    thanks again for y our patient help with this.


Log in to reply