Not Synchronizing

  • On my hosting server the Consensus Db file got accidently deleted while sia was running. That send the complete installation down the drain, all contracts lost.

    However, i have now deletet all data from AppData\Roaming\Sia-UI and used a fresh installation pakage, but it does not synchronize.
    I have made a new installation on 2 different computers that had no sia before, and they do not synchronize, too. I have a third old installation with a different wallet, that does synchronyze. Why don't the others ?

    (All Computers have a internet connection)

  • Did you restart the computers after uninstalling Sia? What does it say in the log files?

  • 2 of the computers never had sia on them. the third one has been powercyled several times.

  • @Kermit
    Is Sia-UI appearing as working? You can unlock your wallet, but it is not syncing the consensus?

    If so I suspect insufficient "gateways".
    Can you look (paste here) at the output of gateway list in the terminal?

  • Ui is working.

    The one computer that syncs has just two gateways :

    gateway list

    2 active peers:
    Version Outbound Address
    1.2.2 Yes
    1.2.1 Yes

    The others that do not sync have no gateways :

    gateway list

    No peers to show.

    So how do I get more gateways ??

  • @Kermit
    So that is the problem why those don't sync.

    You can on the hosts not syncing type in terminal:
    gateway connect
    gateway connect

    In addition, you can add some more (the same way) from my list:
    1.2.2 Yes
    1.2.2 Yes
    1.0.0 Yes
    1.2.2 Yes
    1.2.2 Yes
    1.0.0 Yes
    1.2.1 Yes
    1.2.2 Yes

    There is an issue with newer (1.3.0) nodes behind NATted connections not being able to connect to other 1.3.0 nodes.
    I really hope the devs will make a hotfix to solve this problem soon. As dumb as it sounds, it is so that the old (<1.3.0) nodes are keeping the whole network alive for the new nodes behind a NAT firewall/router.
    And if no gateway nodes are reachable, the syncing stops...

  • Thanks for your help.
    I tried to connect to your nodes, but none of them worked. I always get :

    Could not add peer: dial tcp connectex: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat.

    When trying to connect to one of the peers from my working computer, the connection is succesfully made and sometimes he starts to synchronize for a very short time, but is always dropped immidiately. (gateway list shows no peers)

    I then terminated all other sia's and added the gatways again, and now they stay and he synchronizes very slow. (I have a consensus db copied so he started at 98%)

    So there seems to be a problem with several siad running on different machines behind the same nat with the same ip.

    What is the normal way of sia to get more gateways ?

  • @Kermit
    I added all my local nodes as gateways via the local network IP to all other nodes. Though, I have only 3-4 running nodes.
    I am not sure, but when at least one node has synced, your other nodes can get the consensus over the lan from that one node.
    1.3.0 nodes connect well within the LAN, the problem is when NAT interferes.
    so just gateway connect <local IP from the "main" node>:<RPC port on that>

  • I found this page after 4 days of looking for a solution, been through bootstrapping the blockchain twice (which doesn't seem to work anymore BTW, just gives an error after reading in the db file from, two different PC's, multiple websites. Very crappy experience.

    Can you imagine if Sia was actually user friendly how much that would help it's popularity?

    For example for this problem, detect that synchronizing hasn't started (easy to do), auto detect if there are no gateways (easy - already does this), and do something about it (add gateways or inform the user).

  • @Dodgums : I agree. SIA is not the most user friendly chain. Upgrading the user experience will increase it's popularity for sure.

  • My own experience of "not syncing" with 1.3.0 is the same as yours.
    I deleted everything and started with v1.1.0.
    It started syncing straight away.
    When it's done, I'll update to v1.3.0.

Log in to reply