Wallet restore without backup

  • Sorry for the question but how should I run the 4. wallet -> restore from seed -> put old seed?

  • @gigacoin
    If you deleted the wallet.db file Sia-UI will ask what to do when you try to look into the wallet section of the UI.
    It will ask if you want to create a new one or restore an old one.
    Click on restore (on the right side, I do not remember the exact text it shows).
    It will ask you for the seed, there you paste (or type) your old seed.

  • If I shutdown Sia-UI then the delete wallet.db and restart happens nothing, normal start.
    In the folder appears again by itself the file wallet.db ???
    What am I doing wrong?
    I think I completely delete everything and instal again. The question would be with initial equipment I should give the old seed or only create a new one and then try to load the old one?
    Although I have already tried both.

  • @gigacoin
    You are doing right, The UI creates an empty wallet.db.
    It appears to be working normally, the blockchain syncs.
    Just when you try to open the wallet, The UI will see there is no initialized wallet and will ask what to do.
    It is easier to restore the wallet with the old seed than to load into a new wallet.
    Perhaps it is easy enough to load the old seed into a new wallet, but I've seen repeatedly people asking what is going wrong doing that. So I have the impression it is easier to restore the wallet from seed than to load it into a new.

    Technically loading an old wallet into a new one should make a new transfer transaction where all available balance is transferred into the new wallet. The old wallet is not erased from the blockchain. It gets simply emptied.
    So in your particular case it could be that you succeeded in loading the old wallet and emptied your old.
    So if you successfully restore your wallet and it shows 0 balance you should see a transaction transferring your coins.
    Then you should restore your new wallet with your new seed.

  • Thanks for your effort to help me but I think I have tried everything without success.

    I have deleted the file wallet.db again and Sia-UI restarted without notification that I must enter a seed. Then I opened my wallet with the new seed and entered the old seed under Wallet -> Recover Seed -> after a few minutes the message:

    Sia-UI Wallet Error
    Error when calling / wallet / sweep / seed: consensus conflict: provided transaction set is standalone and invalid: transactioncontains a frivolous signature

    I just have to accept that the coins are gone, sad.
    This is what SIA has done for me.

  • @gigacoin
    I have never seen this error.
    So, to recall the restore old wallet procedure, did you try to not create a new wallet?
    I mean after deleting the wallet.db you can't just open (unlock) your wallet with the new seed. It is deleted. If you can, it was not deleted... The wallet with the new seed can not simply resurrect.
    Either you did not delete the right file or you restored the new wallet with the new seed.
    Was Sia-UI closed and shot down when you deleted the wallet.db? No running "siad" process at that moment?

  • I deleted the file wallet.db in the folder .... AppData \ Roaming \ Sia-UI \ sia \ wallet
    Sia-UI was closed at this moment and process ended.
    If I start Sia-UI nothing happens without the wallet to unlock the file wallet.db comes back by itself. The wallet I can only unlock with new seed not with the old seed. I have made new seed and linked to old as described above. In the hope that my coins will appear in the new seed. But has not happened.

  • @gigacoin
    This is impossible. You can not unlock anything if the wallet.db is deleted. You can only create a new wallet or restore from seed.
    If you can't restore with your old seed but can restore with the new seed, you have an error in your old seed.

    So I am sure your wallet.db did not get deleted.
    If you can unlock (without restoring) your wallet, you have not deleted the (right one) wallet.db... Or the Sia daemon was still running when you deleted and thus the file got recreated.

    So, to be sure, try without the UI.
    start your command line (cmd.exe).

    cd <full path to your unzipped Sia-UI>\resources\app\Sia\
    start siad.exe
    siac wallet init-seed --force

    write your old seed when prompted.

    What is the response after that?
    Does siad open a new window and show something?

    did you see any coins in your wallet at some point of time ever? What and why do you expect to discover in your wallet? Did you transfer coins to your old seed address from exchange or mining pool?

  • Hey,

    so with the cmd.exe command does not find my path, does not ask why?
    You are right there is something wrong, the file wallet.db is 0kb?
    Yes before I uninstalled the wallet, I saw with the old Seed coins in my wallet.
    I send coins from Poloniex in my wallet to this Address: ee8ff8c504ca3b73810ecda179a98e660fca5812c3edbfbf7d98bb2cb0591f01f3d6ddddcb3e but never saw this coins. After this i uninstalled my wallet. I try delete everything and try to reinstall everything completely and restore the old Seed with new wallet.

Log in to reply