Introducing SiaBerryOS: A Linux Operating System for Using Siacoin on Raspberry Pi 3



  • @nexeon9 Please use the latest build, 1.2.1. Actually the IPv6 restriction (the reason you see the error as it needed IPv4 in the earlier versions) has been removed.



  • @nivelblue Please use the latest build if you have not yet. The issue has been resolved in 1.2.1.



  • @cit Glad you have is set up. Actually siaberryos.local thingie should just work. Usually chrome initiates a search instead of directly going to the web-UI. But if you had tried it using firefox, and even with chrome (writing the address with http:// to prevent the chrome from interpreting it in google) it would definitely have worked. Also, don't forget to install Bonjour service as explained in the quickstart guide.



  • @surfnomada Could you come to discord? Actually that way is much more efficient as we can solve all of the possible problems and guide you through the procedure all at once and fast.

    Basically it is just writing the image into a microsd and booting it. Even a monitor is not required. Once you get the very first steps done, the rest would be a breeze for you.



  • I got it working but i would like to see the host price configurations easier to understand. What is H/Byte/Block and H/Block? The official Sia UI uses Sia coin as a reference.



  • @clip203 It is what has been set in Sia API. In Siaberry you can tweak more settings for hosting. Basic settings will be implemented in the next releases.



  • @kete Thanks for the reply. I look forward to the Basic settings. How do you plan to do renting if at all? I think it's a great hosting tool but it could be tricky with renting.



  • @kete My siaberry host is rebooting every 3-4 days. Nothing is in the logs from what i can see. Anywhere else i can check?

    Feb 6 04:00:01 SiaBerryOS CROND[9616]: (root) CMD (wget -O /tmp/CommonAPI https://explore.sia.tech/explorer)
    Feb 6 04:00:02 SiaBerryOS CROND[9612]: pam_unix(crond:session): session closed for user root
    Feb 6 04:05:01 SiaBerryOS crond[13517]: pam_unix(crond:session): session opened for user root by (uid=0)
    Feb 6 04:05:01 SiaBerryOS CROND[13521]: (root) CMD (wget -O /tmp/CommonAPI https://explore.sia.tech/explorer)
    Feb 6 04:05:09 SiaBerryOS CROND[13517]: pam_unix(crond:session): session closed for user root
    Feb 6 04:08:44 SiaBerryOS init[1]: Switching to runlevel: 6
    Feb 6 04:08:44 SiaBerryOS CROND[9613]: pam_unix(crond:session): session closed for user root
    Feb 6 04:08:46 SiaBerryOS kernel: zram0: detected capacity change from 536870912 to 0
    Feb 6 04:08:46 SiaBerryOS kernel: zram: Removed device: zram0
    Feb 6 04:08:46 SiaBerryOS watchdog[3524]: stopping daemon (5.15)



  • @kete I have been having the consensus error in version 1.2.3. Ive reflashed the os on 3 different sd cards but I still get the error:
    Downloading or continuing the download of consensus.db ...
    Resolving siaberry.com... failed: Temporary failure in name resolution.
    How do I resolve this?



  • Thanks for all your work on this, I bought a Pi 3 to try it out, followed all the steps in the instructions and with a bit of perseverance I am up and hosting. There are a couple of things I'd like to feedback on;

    1. Admin Login seems fussy, I often get knocked back on the first login, I just do it again and it works.

    2. Blockchain sync took at least 24 hours+, I did switch the device on and off (hard off, just pulling power plug and putting it back) and it seems to pick up from where it left off. If there was some way to display blockchain sync progress (x% of blocks?) that would reassure users something is happening.

    3. Generate address, I had some problems where I'd click and it just seemed like nothing was happening, so I just kept repeating the instructions and it worked after a few attempts, I think maybe it takes a while to generate an address (minutes?), so again, some visual feedback in the UI would help here.

    4. Maybe hide all the optional settings in the hosting panel and add a bit more description about what the common defaults you might want to change do, or even better, some kind of calculator that can compare pricing with live prices to give some guide of where to price your hosting.

    5. Some kind of notification (email?) when my hosting is being used would prevent me reloading the page every hour....

    6. The UI artwork and colours are a bit tacky and rather spread out, this could be condensed a fair amount and kept usable, obviously not as important as function, it would be nice if you took the sia colors (the green/dark blue) and used that throughout to create a consistent feel across the products, I could do some mockups if that would be helpful ?

    That's it, thank you again, nice work, seems very stable, I've pulled the plug on the device numerous times and it comes back afterwards reliably, on first install I messed up setting the password, make sure if attempting you read carefully, maybe in the doc replace 'Kete' with a reference to the username that you've created.



  • I get "Error calls" = 54 under hosting what is this? Did you have an Error FAQ? I also try 2 times discord with the same question and google.



  • @clip203 SiaBerry reboots itself every week to keep Sia version up2date.



  • @ckc82084 Sorry for my late reply. Do you still get that message? If so, could you please post on reddit /r/SiaBerry ? There is another thread having your problem. I am not sure if the OP is you or not but it can help you set it up in case you have not succeeded in removing the problem yet.



  • @ther

    1. The login implements a special way to decrease the load on the Pi. Actually there is not database software running. What you see as getting knocked back sometimes is a result of very strict login checking. Yes, it sometimes happens but it is harmless.

    2. Yes, right now on a Pi which only has USB 2.0, a USB3 pen drive can take up to a whole day. That is normal. Unfortunately there is not a way to show the progress while you are bootstrapping but that might be added to the Sia core itself later.

    3. Generating an address should not take a long time if not instantaneous. You might have tried to generate one while Siaberry was scanning the blockchain probably? Like when you unlock your wallet for the first time.

    3/4. That is a good feature and is already on the list. You know, the development list is somehow prioritized. But we will reach that part as well!

    1. I tried to make the look appealing while being easy on the eyes. I have tried to create a color distinction so that every piece of info can be read easily. But if you or anybody else have ideas, they are appreciated! Please post your suggestions on /r/SiaBerry so that it will stay documented.

    2. Thank you too for the suggestions! The OS itself is very stable but do not try to cut the power without properly shutting down the device as it might corrupt the SD card or even the Pen drive. About the howto, I have intentionally put "kete" and following that command, I have said that the user must change kete with his/her own user name which helps the user remember that he/she is supposed to change the user for better security.



  • @cit It is normal. Every host gets those!



  • Hello everyone. Ive been toying around with Sia-UI for a month or so. I've gotten a couple of hard drives setup to to share via Sia on my Slackware machine but decided to move over to a Raspberry Pi 3. So, I downloaded SiaBerryOS and booted up with monitor, keyboard, mouse, and ethernet cable all attached along with a 500Gb external drive. Once the system prepares itself and reboots I am able to login at the command prompt (there is no GUI) but the Raspberry has no internet connection....anyone have any ideas what I'm doing wrong?

    Thanks in advance.


Log in to reply