Introducing SiaBerryOS: A Linux Operating System for Using Siacoin on Raspberry Pi 3

  • Hi there, will this operating system work with a Raspberry Pi 2?

  • @jackk Sorry for not responding earlier. I had not checked this thread at all as I am always on our discord channel. Anyway, no it will not work as Raspberry pi 2 does not support 64bit architecture.

  • I'm a noob when it comes to raspberrys and Linux and all this stuff, so I was happy when I learned that there is an easy way to setup a host for SIA with a raspberry. I do have the possibility to get free highspeed internet and a high-availibility power resource at work, so I just tried to set up a raspberry 3 with Siaberry OS v1.2.

    To be true, I failed on the first step already. I cannot control the router and DHCP is not activated. Instead, I was given a fixed IP. But how can I set it up on the raspberry? I see that it is booting and running when attaching a screen, but I can't access the raspberry neither via WebUI nor via SSH. Could you please give advice?

    Thanks a lot!

  • @Percy Sorry that I could not respond to you earlier. I lost my password and could not recover my account until recently.
    About your problem, if you are still facing it, can you explain more? What is the error message?
    Also, you can join us in discord #siaberry so that we can solve it more efficiently.

  • I installed the SIAberry but unfortunately stuck at trying to login. When I try to go to siaberryos.local it gives me error
    403 Forbidden
    "You don't have permission to access / on this server."
    Apache Server at siaberryos.local Port 80

    and the web-ui is not displayed. Any idea?

  • @kete I'd like to join #siaberry on discord but have never used discord and can't seem to figure out how to join. Do I need an invite?

  • @tmciver
    DM siabot in discord .chan add siaberry

    You can also find me on Sia Official Discord.

    Donations are welcomed.
    SC: e8f701c1b2b37c8560cd9bbd2ab85e352d27112f51f0cec815a1331dcc2257392f6b53440b4c
    DCR: DsSKZQkB1MZ81o5DtePbmC3swPCzgbtdg6f
    ETH/ETC: 0x5d67690768F0Fc4780c578393Ca567e5bCb38378


  • Hi. I'm trying to install siaberry but when I try to download the file "consensus.db" I get the following:

    Resolving failed: Temporary failure in name resolution.

    Could Algiuen tell me if I'm doing something wrong or what I should do to solve the problem? Thanks in advance

  • HI,Thanks a lot for the guide.I think I understand everything but one thing.First I have to say that I use Mac for this.
    When you say the two have to "Write the image to the Micro SD card in your laptop and Replace SDX with the block Device..I am lost there.I guess its not just to copy the image on MIcroSDcard right? how are we supposed to do this? from the "Terminal" ?

    Also, why do we need a USB3 flash drive for?

    thanks a lot.

  • [email protected]
    Just a little comment.I love the project and all, and I really think its a great idea but c´mon.:Do you really think any potential user its going to go through the whole process of opening the ports( a fucking mess for anyone not use to this things) and in the case of the raspberry pi installing the operating system?

    I am a complete kook with computers ,still I have taken a few afternoons already to learn how to host.Even reading forums and staff and with the instructions, the hosting thing is not working on my mac.

    Once the ports are open(or so I thought) the siacoin app showed Host connected so I pushed the Announce and of course it charged me 0.018SC.It hasn't work and then the Host appears as not connected suddenly.
    I have spent 2 SC trying this with zero success.

    So some money spent and a lot of time and nothing.

    Also I am trying the raspberry pi hosting which is a whole new level,aslo fucking complicated.
    I have learned to flash the OS on the SD OS of the berry but again some problem with the MacBooks SD reader makes it impossible.
    Three evenings spent on this and zero results.

    My point being, theres gotta be an easier way to attract people to the project and of course make us pay for our efforts is not the best way.

  • @ kete
    Big thank you for the hard work.

    You need to unpack the Image.xz "SiaBerryOSv1.2.img.xz'" (use 7zip)than bourne it like a DVD/Blu-ray) on your microsdcard. worked for me.I used an microsdcard to USB Adapter.

    Connect the rasberry 3b before the first boot to Network cable and router, and some TV so you can see what happen.!! ....If not ,you perhaps can't get Network to work. I tryed first boot whitoute conection.. and can't find out how to Change IP. I fixed it wite rewriting the Image to the microsdcard and connected everything before first boot and it worked . After that you can see the ip of the siaberry in the prompt in TV , or you use a toll like ""fing" for ios or android to find the ip if you can't find it in your router .It was named " recovery" in my router and not siaberry or rasberry some confusion for me. After that you can hit the ip in every browser you have in your "Lan" configure the siaberry to your conditon. I use the IP cause siaberryos.localblabl did not work for me. It loads the chain more than a day ,wallet unlocking trigger cause of new Wallet Setup need a few hours. But it works.

Log in to reply