Fixing the HTTP 404 Miner Error



  • I've seen a few people struggle with this error so I decided to make a quick write-up based on my github post: https://github.com/NebulousLabs/Sia-GPU-Miner/issues/59

    Typically this error indicates that although the miner found a siad instance running, but that siad instance is not fully setup for mining. The fix is fairly simple. These instructions assume you are using the latest version of the Sia-UI (v1.2.2 as of writing) and the sia-gpu-miner (v1.1.0). You can get both through the "Sia Links" side bar. --->

    1. Quit Sia-UI (using the Quit Sia option shown by right-clicking the notification tray icon) and try starting the siad agent directly.

      For Windows: C:\Program Files (x86)\Sia-UI\resources\app\Sia\siad.exe --modules cgmhrtw -d %appdata%\Sia-UI\sia

      For Linux (depending on how you installed it): siad --modules cgmhrtw -d ~/.config/Sia-UI/sia

    NOTE: It may take a few minutes for Siad to finish loading, it took six for me with an SSD.

    1. Relaunch the Sia-UI (it will bind to your manually started siad instance)

    2. Unlock your wallet

    3. Retry the miner start command in the Terminal Plugin. Assuming you get a CPU Miner is now running. message the last step is to retry the sia-gpu-miner. Make sure you are running the latest version (v1.1.0).

    4. a. If you are on Windows and want to run with the default settings, you can simply double click the sia-gpu-miner.exe file.

      b. Otherwise open up a command terminal and navigate to where you downloaded the miner. Once there type sia-gpu-miner and press enter.

    5. You should see a message stating the miner is initializing, followed by the hash rate a few seconds later.

    6. You will likely want to modify the intensity setting for the miner to best match your card. This can be done by passing the -I option to the miner, i.e:
      sia-gpu-miner -I 27

    7. You will most likely want to stop the CPU miner with the miner stop command in the Terminal Plugin. Most CPU's can do 0.1% of a GPU with a much higher power consumption per hash.

    On average a 1GH/s mining rate will get you on average ABOUT 1ks per day. Keep in mind these numbers change, and it comes down to either getting a block or not. That means you can go months without getting anything but then hit a ~200k SC block, but then get nothing for several more months. If you are looking for a more stable mining income, you might want to look into one of the mining pools available for Sia.

    Happy Mining!



  • I am completely new to this, but I have got the same problem. When Sia UI is running, and I start the miner i get the 'http 404' error.

    When I quit Sia-UI, and try to open said.exe it only shows "This is a command line tool. You need to open cmd.exe and run it from there"

    The terminal shuts down again, and thats all that happens.

    What am I doing wrong?



  • I am receiving the same error as RockinRein. I attempt to open the .exe file and receive "this is a command line tool. You need to open cmd.exe and run it from there". Any help would be greatly appreciated!



  • @RockinRein I think I figured it out! Haven't quite yet started mining b/c I'm still waiting on the sync. Open up the folder containing the siad.exe. Rather than double-clicking it to initiate it, drag and drop that file into a cmd promt and press enter. I didn't have access to the gateway when i did this, so if you get the same issue just open up cmd as an administrator and type the same exact text of the file location of the siad.exe from the original cmd window and it'll run. Once it's finished loading (6/6) open up the Sia-UI.exe file under your main folder and go through the steps of creating your wallet and syncing. Feel free to keep your admin cmd window open to see the progress. Hope this helps!



  • Ah, that seems to be working! I am now Syncing (again) and just to be sure, I made a new wallet. Lets hope it works now :)



  • I am still getting the HTTP 404 error... Is your fixed now @Timealien ?



  • The fix: Use Merlin instead. Working like a charm now!



  • @droghio said in Fixing the HTTP 404 Miner Error:

    1. Relaunch the Sia-UI (it will bind to your manually started siad instance)

    This results in:

    A critical error loading Sia has occured: Siad unexpectedly exited. Error log: Loading...
    (0/7) Loading siad...
    listen tcp 127.0.0.1:9980: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.


Log in to reply