A critical error loading Sia has occured: Siad unexpectedly exited

  • @droghio I just opened Sia.UI from the main program folder on my desktop. I'm not super technical but was able to follow xancel's instructions through cmd.

  • @xancel worked for me. thanks a ton!

  • I have a similar error...

    A critical error loading Sia has occured: Siad unexpectedly exited. Error log: Loading...
    (0/6) Loading siad...
    (1/6) Loading gateway...
    (2/6) Loading consensus...
    (3/6) Loading transaction pool...
    (4/6) Loading wallet...
    (5/6) Loading host...
    Closing wallet...
    Closing transaction pool...
    Closing consensus set...
    Closing gateway...
    unable to load the legacy storage manager persist: open C:\Users\XXXXX\AppData\Roaming\Sia-UI\sia\host\storagemanager\storagemanager.json: The system cannot find the file specified.

    I've tried deleting and reinstalling the wallet but I got exactly the same message. Looking in the above path, the mentioned file isn't there. Does anyone know what it is supposed to be? Can I simply create a new file and name it accordingly or does it provide instruction rather than simply being a storage space?

  • I'm having the same problem. Got it to sync to 98% then this happened....twice!!

    @xancel It looks like what you did should work for me too, I'm just not understanding how to do that in cd. Could you give a little more detail? Would be much appreciated. Thx

  • ok... Ive managed to open in cmd this:


    But there is no siad.exe file. There is a siac.exe file but then I get this message:

    Could not get current consensus state: no response from daemon

    There is however a siad.exe.fig but I don't think that will be any use.

  • I have the same problem with MacOs 10.12.6 someone help me please :S

  • Guys i have the same issue with MAC. Any solution? Thanks

  • Nobody can assist here? We stuck with this thanks

  • @xancel Works 100% for me! Thanks!!!

  • yes, i also solved the error! Thanks xancel !!!!!

  • @xancel Can you please help me figure how to do this for mac?

  • Thanks @xancel I believe this will work for me too.

    If you're still having problems running siad.exe via cmd:

    1. Open cmd as admin (click Start and type cmd, right click on Command Prompt and Run as Administrator)
    2. Type cd C:\path.to.siaUI.folder and then press enter
      Example: If you have your SiaUI folder in the root of C you would use this cmd: cd C:\Sia-UI-v1.3.1-win32-x64\resources\app\Sia
    3. Now just type siad.exe and hit enter, you will see output similar to my screenshot below
      Note: My SiaUI folder is on my desktop. Here is a sceenshot (I blacked out my Windows user name)
    4. Wait for siad.exe to sync (open taskmanager and look for siad.exe and wait) I've been waiting for 30+ mins now. It is still downloading and writing to the disk drive.

Log in to reply