Host Unreachable

  • Hi!
    I wanted to be a host today,but in the Hosting page,it showed “Host Unreachable”!When I put the mouse on the button ,it showed tips:"Your host is not connectable at the configured net address.Check your UPNP or NAT settings".

    Can you tell me how to solve the problem!Apperciate your answer!Thank you anyway!

    Here is the image:

  • @forest21000 You may have to check if you have ports 9981 and 9982 fowarded. If not, you can follow publicly available steps to first set a static IP and then configure your router to forward these ports. The same issue happened to me and that's what I did to fix it.

  • Thanks for your answer!You are right,the ports are not fowarded .So I will follow the publicly available steps to first set a static IP and then configure my router to forward these ports.
    Thanks again!

  • I have this problem too. (Currently on windows 10).
    I checked in my router, the ports 9981 and 9982 are forwarded, TCP and UDP for both ports. I guess the UPNP has put these 4 rules into my router. I even see there was traffic under these rules. But the UI tells me that my host is unreachable.

    I guess it has something to do with the windows integrated firewall. I remember a similar issue with another program which I got accessible only if the windows firewall was disabled.
    I thought I have a good router/firewall on the incoming internet cable and it is partially safe to disable the windows firewall but it turned out Microsoft does not allow me to use other apps if the firewall is disabled. For instance I couldn't use the windows calculator after a while...
    This is one more reason for me to move the sia node away from windows if I plan to host.

  • Was this resolved. I am getting the same issue.. I have opened TCP ports 9981 and 9982 on router, McAfee, and windows firewall(for safe measure)... connects for about 10 minutes then dumps me. Any feedback is welcomed. thanks

    Unofficial User / Tester / Analyst of Sia ( w/Renter and Host experience)


  • I believe this issue can be resolved (given ports are open) by sending in the announcement tokens. Without the 1 time announcement token sent in the nodes will time you out. Despite ports being open. Hope this helps.

    Unofficial User / Tester / Analyst of Sia ( w/Renter and Host experience)


  • Sending the announcement tokens does not resolve the issue as I had done that before the issue began.
    I also tried it again after it started.
    It seemed to start after I upgraded to 1.2.2, but I downgraded to see if it persisted and it did. I had only been using sia for a few days before 1.2.2 was released.

  • when you say "using" are you referring to hosting?
    If you were hosting this would mean you had ports open- but you also wouldnt be getting that msg.

    If you have never hosted then I would think the ports also have never been opened if your continuing to get the "unreachable host" your ports are not open either on the router or firewall.. or if running windows 10.. check the windows firewall as well. Also use this website to confirm the ports are in fact open.

    Unofficial User / Tester / Analyst of Sia ( w/Renter and Host experience)


  • Same problem.. Over the course of a day it will alternate between being connected and not. Running 1.2.2 on Windows. I tried restarting the application, re-announcing, etc., but the problem persists.

  • @jeff Its a port issue. Check your router... also as a insider tip if using windows.. also config the windows fireall to open those ports.. and any specialty software like McAfee Firewall. But usually router is the blame for a connect and then a disco.

    Unofficial User / Tester / Analyst of Sia ( w/Renter and Host experience)


  • I have the same problem. Web sites confirm that I'm reachable on 9981 and 9982. Client says that I'm online and hosting all the time when I check. Yet, I miss random online scans. WTF? I'm mining on this rig, so it's not sleeping or anything. My score is horrible and I'm about to give up. :(

  • @forest21000
    I made a new post to hopefully help some user open their ports. Link here

    Unofficial User / Tester / Analyst of Sia ( w/Renter and Host experience)


  • @jeff Turns out I had to manually open the ports in my router. Not sure why it still managed to connect sometimes considering the ports were closed. Maybe it depends if it's the host that's calling outwards, or if it's the clients that are polling the host? But I don't know how the protocol works. I had the feeling the issue had something to do with inbound/outbound connections as used with iptables. If it's outbound it works, if it's inbound it doesn't... until you unblock everything.

  • This is not only a ports problem. I have created a Host just today, opened my ports and started advertising for contracts. For the first few hours, all was fine and the host was reachable. I glance at it now and it is unreachable. I was reconing this based on customer requests, but if I cannot get this to work then I certainly cannot recommend SIA to my customers. Nice idea, thus far, but no good if it does not work. I also will not tolerate getting penalized for a poor interface when my configuration is fine.

  • I had this problem for a few days now. Here's how I fixed it -
    I'm running the Sia-UI v 1.3.0, Windows 10, Symantec Antivirus and a Linksys router with Smart Wi-fi.

    First, the Sia-UI wasn't announcing the correct IPv6 address for me. Google "my Ip address" and make sure the address you're announcing is actually your public IP address. I double checked with ipconfig and they were different. When you hit the announce button you can edit the address being announced. Be sure not to remove the port - I believe the syntax was [your IPv6 address]:9982.
    Next, I realized that I was running multiple firewalls. My antivirus runs one and my router runs one. With Symantec click options under network threat protection and configure the firewall rules to allow traffic for ports 9981-9982 using TCP. UDP wouldn't be appropriate here. Also, I had to allow traffic through the firewall on my Linksys router by going to Security in the Smart Wi-fi main screen and clicking "Add IPv6 Firewall Setting." Again using 9981-9982 using TCP.
    If you don't have an antivirus and you're using windows firewall you'll need to go to Windows Firewall>Advanced Settings>Inbound Rules and add a new rule with the same configuration.

    Additionally, in my router, I had to go to the Apps and Gaming Tab of the Security page to port-forward 9981-9982 to the correct IPv4 address.

    Once I made these configuration changes I restarted the Sia-UI and was able to connect to the network and find my IPv6 address on

    EDIT: I debugged this with Wireshark. It's an invaluable tool!

  • For anyone still having this problem, I found it helpful to disable IPv6 in my router :D After that, it worked

Log in to reply