Load wallet no balance showing (v.1.2.1 OSX)



  • Hello,

    Before I move coins over to my offline SIA wallet, I've been testing Sia-UI 1.2.1 OSX.

    I can't seem restore a wallet and have the balance show, but I can sweep the seed into a new wallet. To troubleshoot the load seed and no balance I:

    • for all tests blockchain was synchronized (according to the UI).
    • deleted the wallet directory and tried again
    • killed siad in the activity monitor and restarted it in the wallet tab in the Sia-UI
    • deleted Sia-UI completely, resynced blockchain and loaded seed again.

    none of those were able to show my balance from restored seed. as mentioned though I was able to create a new wallet and click "recover seed" and sweep my old balance into the new wallet.

    please help, would like to get load seed working to get some trust going with the Sia wallet :)

    also, are there any resources to web to just run the wallet on os-x via command line / terminal for the wallet functionality (not the file stuff)?



  • Could this be related to this ; https://github.com/NebulousLabs/Sia-UI/issues/581 ?



  • I saw this thread. Not entirely the same. Similar.

    • I send from polo and the balance -does- show up
    • I delete the wallet to test restoring my seed
    • I can't get the balance back after restoring -- even after reinstalling sia completely...(yes was synced)

    -the 99.8% syncing happens to be and then syncs after a min but did t perceive that to be an issue....



  • hi, identical situation here, transferred balance from polo, maybe 1 year ago.. since it was installed the balance was always there, now i changed computer i tried to recover seed, first time it seemed to recover, but balance was 0, now when i try it give me tis error:

    error when calling /wallet/sweep/seed : cannot sweep primary seed



  • @hargossath i'm a bit worry, because i have 200000 sia in there



  • Known bug. It will be fixed in the next version 1.2.2.



  • Try downloading the latest RC, it fixes this bug: https://pixeldra.in/l/KT8dJH . Should be able to delete your wallet, then use the 'Load from seed' functionality to recover your coins.



  • hi, i tried (windows version) and nothing, it gave's me the same problem



    1. You must turn off sia (quit in tray icon)
    2. rename wallet folder in app data %UserProfile%\AppData\Roaming\Sia-UI\sia\
    3. run sia v1.2.2
    4. click "Load a wallet from a seed"

    It didn't work because you were importing the seed to the wallet created from the same seed.



  • Another solution for this problem, that generates a new seed and transfers your coins into that seed:

    1. Enter wallet init --force in Terminal
    2. Save this seed (it's where your funds will be recovered to)
    3. Go back to the wallet, unlock
    4. Use Recover Seed


  • Hello,

    I initially sent some Sia to my UI wallet from Polo, and it showed up within a day. I sent more to the same wallet (but different address) and now the the blockchain explorer doesn't recognize the transaction, even though Polo says it was sent. Have I not waited long enough, or am I missing something?



  • Same problem with me. Meanwhile I did an update to v.1.2.2 but there is still no balance in the account.

    Could anybody provide a step by step instruction, without creating new seeds?

    @stealthx: could not find "%UserProfile%\AppData\Roaming\Sia-UI\sia" on maxOS (Sierra)

    Thanks, Peter



  • @crypto_pete on MacOS the location is ~/Library/Application Support/Sia-UI/sia


Log in to reply